"Paquete 'linux-headers-3.13.0-27-generic' no tiene candidato de installation"

Estoy tratando de resolver un problema que publiqué aquí . Básicamente estoy tratando de ejecutar este script con éxito. Para hacer eso, creo (y es muy posible que esté equivocado) Necesito instalar el package linux-headers-3.13.0-27-generic . Pero el command de installation siempre está fallando

 mg@MG-7520SE:~$ sudo apt-get install linux-headers-3.13.0-27-generic Reading package lists... Done Building dependency tree Reading state information... Done Package linux-headers-3.13.0-27-generic is not available, but is refernetworking to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'linux-headers-3.13.0-27-generic' has no installation candidate 

La búsqueda con apt-cache search no arroja un resultado válido porque ninguno de los resultados devueltos coincide con la versión que necesito, que es 3.13.0-27

 apt-cache search linux-headers linux-headers-3.16.0-23 - Header files related to Linux kernel version 3.16.0 linux-headers-3.16.0-23-generic - Linux kernel headers for version 3.16.0 on 64 bit x86 SMP linux-headers-3.16.0-23-lowlatency - Linux kernel headers for version 3.16.0 on 64 bit x86 SMP linux-headers-generic - Generic Linux kernel headers linux-headers-lowlatency - lowlatency Linux kernel headers linux-headers-virtual - Transitional package. linux-libc-dev - Linux Kernel Headers for development linux-libc-dev-arm64-cross - Linux Kernel Headers for development (for cross-compiling) linux-libc-dev-armel-cross - Linux Kernel Headers for development (for cross-compiling) linux-libc-dev-armhf-cross - Linux Kernel Headers for development (for cross-compiling) linux-libc-dev-powerpc-cross - Linux Kernel Headers for development (for cross-compiling) linux-libc-dev-ppc64el-cross - Linux Kernel Headers for development (for cross-compiling) linux-source-3.16.0 - Linux kernel source for version 3.16.0 with Ubuntu patches linux-virtual - Minimal Generic Linux kernel and headers linux-headers-3.4.0-4-goldfish - Linux kernel headers for version 3.4.0 on Android touch emulation linux-headers-goldfish - Linux kernel headers for the goldfish kernel. linux-headers-3.16.0-24 - Header files related to Linux kernel version 3.16.0 linux-headers-3.16.0-24-generic - Linux kernel headers for version 3.16.0 on 64 bit x86 SMP linux-headers-3.16.0-24-lowlatency - Linux kernel headers for version 3.16.0 on 64 bit x86 SMP linux-headers-3.16.0-25 - Header files related to Linux kernel version 3.16.0 linux-headers-3.16.0-25-generic - Linux kernel headers for version 3.16.0 on 64 bit x86 SMP linux-headers-3.16.0-25-lowlatency - Linux kernel headers for version 3.16.0 on 64 bit x86 SMP 

Mi información del sistema

 mg@MG-7520SE:~$ uname -a Linux MG-7520SE 3.13.0-27-generic #50-Ubuntu SMP Thu May 15 18:06:16 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux mg@MG-7520SE:~$ lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 14.10 Release: 14.10 Codename: utopic 

Bueno, desde la apt-cache search linux-headers la causa debería ser obvia:

En pocas palabras, el package no está disponible en Ubuntu 14.10. En su lugar, debes instalar linux-headers-3.16.0-24 , linux-headers-3.16.0-25 o salvarte de todos los problemas y usar linux-headers-generic que es un metapackage que depende de los últimos kernels disponibles ( pasando por su otra pregunta en Ask Ubuntu, parece que está utilizando 14.10 con el kernel de 14.04, que es un gran no-no, instale también el package linux-image-generic , o mejor aún, linux-generic que le asegura tener el último par kernel-header disponible, y reiniciar el sistema).