freeBSD: Editor de text Atom

Instrucciones de compilation del editor de text Per Atom para freeBSD:

pkg install node pkg install npm pkg install libgnome-keyring npm config set python /usr/local/bin/python2 -g 

Entonces:

 git clone https://github.com/atom/atom cd atom script/build 

Esto está en vbox guest con Guest Additions usando FreeBSD-11.1-RELEASE-amd64-disc1.iso que ejecuta Gnome 3.18.2. Win 10 host.

Cuando yo:

 script/build 

Yo obtengo:

  Node: v8.8.1 Npm: v5.3.0 Installing script dependencies prebuild-install info begin Prebuild-install version 2.3.0 prebuild-install info looking for local prebuild @ prebuilds/leveldown-v1.9.0-node-v57-freebsd-x64.tar.gz prebuild-install info looking for cached prebuild @ ~/.npm/_prebuilds/https-github.com-level-leveldown-releases-download-v1.9.0-leveldown-v1.9.0-node-v57-freebsd-x64.tar.gz prebuild-install http request GET https://github.com/level/leveldown/releases/download/v1.9.0/leveldown-v1.9.0-node-v57-freebsd-x64.tar.gz prebuild-install http 404 https://github.com/level/leveldown/releases/download/v1.9.0/leveldown-v1.9.0-node-v57-freebsd-x64.tar.gz prebuild-install WARN install No prebuilt binaries found (target=8.8.1 runtime=node arch=x64 platform=freebsd) In file included from ../deps/leveldb/leveldb-1.20/db/builder.cc:5: In file included from ../deps/leveldb/leveldb-1.20/db/builder.h:8: In file included from ../deps/leveldb/leveldb-1.20/include/leveldb/status.h:16: In file included from /usr/include/c++/v1/string:469: /usr/include/c++/v1/__config:73:2: error: "_LIBCPP_TRIVIAL_PAIR_COPY_CTOR" is no longer supported. use _LIBCPP_DEPRECATED_ABI_DISABLE_PAIR_TRIVIAL_COPY_CTOR instead #error "_LIBCPP_TRIVIAL_PAIR_COPY_CTOR" is no longer supported. \ ^ 1 error generated. gmake: *** [deps/leveldb/leveldb.target.mk:150: Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/db/builder.o] Error 1 gyp ERR! build error gyp ERR! stack Error: `gmake` failed with exit code: 2 gyp ERR! stack at ChildProcess.onExit (~/atom/script/node_modules/npm/node_modules/node-gyp/lib/build.js:258:23) gyp ERR! stack at emitTwo (events.js:125:13) gyp ERR! stack at ChildProcess.emit (events.js:213:7) gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:200:12) gyp ERR! System FreeBSD 11.1-RELEASE gyp ERR! command "/usr/local/bin/node" "~/atom/script/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild" gyp ERR! cwd ~/atom/script/node_modules/electron-link/node_modules/leveldown gyp ERR! node -v v8.8.1 gyp ERR! node-gyp -v v3.6.2 gyp ERR! not ok npm ERR! code ELIFECYCLE npm ERR! errno 1 npm ERR! leveldown@1.9.0 install: `prebuild-install || node-gyp rebuild` npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the leveldown@1.9.0 install script. npm ERR! This is probably not a problem with npm. There is likely additional logging output above. npm ERR! A complete log of this run can be found in: npm ERR! ~/.npm/_logs/2017-11-09T22_00_42_308Z-debug.log child_process.js:621 throw err; ^ Error: Command failed: ~/atom/script/node_modules/.bin/npm --loglevel=error install prebuild-install info begin Prebuild-install version 2.3.0 prebuild-install info looking for local prebuild @ prebuilds/leveldown-v1.9.0-node-v57-freebsd-x64.tar.gz prebuild-install info looking for cached prebuild @ ~/.npm/_prebuilds/https-github.com-level-leveldown-releases-download-v1.9.0-leveldown-v1.9.0-node-v57-freebsd-x64.tar.gz prebuild-install http request GET https://github.com/level/leveldown/releases/download/v1.9.0/leveldown-v1.9.0-node-v57-freebsd-x64.tar.gz prebuild-install http 404 https://github.com/level/leveldown/releases/download/v1.9.0/leveldown-v1.9.0-node-v57-freebsd-x64.tar.gz prebuild-install WARN install No prebuilt binaries found (target=8.8.1 runtime=node arch=x64 platform=freebsd) In file included from ../deps/leveldb/leveldb-1.20/db/builder.cc:5: In file included from ../deps/leveldb/leveldb-1.20/db/builder.h:8: In file included from ../deps/leveldb/leveldb-1.20/include/leveldb/status.h:16: In file included from /usr/include/c++/v1/string:469: /usr/include/c++/v1/__config:73:2: error: "_LIBCPP_TRIVIAL_PAIR_COPY_CTOR" is no longer supported. use _LIBCPP_DEPRECATED_ABI_DISABLE_PAIR_TRIVIAL_COPY_CTOR instead #error "_LIBCPP_TRIVIAL_PAIR_COPY_CTOR" is no longer supported. \ ^ 1 error generated. gmake: *** [deps/leveldb/leveldb.target.mk:150: Release/obj.target/leveldb/deps/leveldb/leveldb-1.20/db/builder.o] Error 1 gyp ERR! build error gyp ERR! stack Error: `gmake` failed with exit code: 2 gyp ERR! stack at ChildProcess.onExit (~/atom/script/node_modules/npm/node_modules/node-gyp/lib/build.js:258:23) gyp ERR! stack at emitTwo (events.js:125:13) gyp ERR! stack at ChildProcess.emit (events.js:213:7) gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:200:12) gyp ERR! System FreeBSD 11.1-RELEASE gyp ERR! command "/usr/local/bin/node" "~/atom/script/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild" gyp ERR! cwd ~/atom/script/node_modules/electron-link/node_modules/leveldown gyp ERR! node -v v8.8.1 gyp ERR! node-gyp -v v3.6.2 gyp ERR! not ok npm ERR! code ELIFECYCLE npm ERR! errno 1 npm ERR! leveldown@1.9.0 install: `prebuild-install || node-gyp rebuild` npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the leveldown@1.9.0 install script. npm ERR! This is probably not a problem with npm. There is likely additional logging output above. npm ERR! A complete log of this run can be found in: npm ERR! ~/.npm/_logs/2017-11-09T22_00_42_308Z-debug.log at checkExecSyncError (child_process.js:598:13) at Object.execFileSync (child_process.js:618:13) at module.exports (~/atom/script/lib/install-script-dependencies.js:9:16) at Object.<anonymous> (~/atom/script/bootstrap:28:1) at Module._compile (module.js:612:30) at Object.Module._extensions..js (module.js:623:10) at Module.load (module.js:531:32) at tryModuleLoad (module.js:494:12) at Function.Module._load (module.js:486:3) at Module.require (module.js:556:17) 

El logging de errores:

~ / .npm / _logs / 2017-11-09T22_00_42_308Z-debug.log

Pensé que comenzaría en lo que imaginaba como la parte superior y probé:

 npm install leveldown 

Sin suerte.

Lo intenté:

 npm install leveldown --llvm-version=5.0 

Eso funcionó por nivel / nivel abajo / no se puede build en freebsd 11.1 # 390

Sin embargo, Atom aún no genera … la misma salida. Tal vez esto ya se haya abordado en otro lugar, pero no he tenido la oportunidad de verlo.

Si bien esto no fue una fiesta en el puerto, hay un error de puerto como se menciona en lovell / sharp / No se puede comstackr para FreeBSD 11, ya no se admite _LIBCPP_TRIVIAL_PAIR_COPY_CTOR # 873

Me encontré con átomo / átomo / Atom no se puede build en FreeBSD 11.0 x86_32 # 6035 pero no estoy lo suficientemente instruido para analizar si los problemas son lo suficientemente similares. No los veo tan explícitamente lo suficientemente similares.

Estoy imaginando que el nivel más bajo es el primer error. Siguiendo esa imaginación, supongo que leveldb es el siguiente error simplemente por el order de la salida. No he tropezado lo suficiente como para nivelar aún.

Lo intenté:

 npm install ~/atom/script leveldown --llvm-version=5.0 

Aún nada.

 leveldown-prebuilt 

Peor. Ernetworking más rápido.

¿Atom no está trabajando para build en freeBSD? ¿Estoy siguiendo el path correcto para resolver los errores? Noté que la salida refs leveldown v. 1.9.

 atom/script/package.json 

dice:

 "leveldown": "^2.0.0", 

pero leveldown parece estar en v. 1.5. No veo eso como una gran diferencia, pero ¿quién soy yo para decir …?

¿Cómo procedo desde aquí para build y ejecutar Atom en freeBSD-11.1?

Gracias por sus comentarios, asistencia y paciencia.

    Intereting Posts