dkms no buildá fglrx

Cada vez que bash build fglrx con dkms para kernel 3.18.22 obtengo lo siguiente:

FATAL: modpost: GPL-incompatible module fglrx.ko uses GPL-only symbol 'pci_ignore_hotplug' scripts/Makefile.modpost:90: recipe for target '__modpost' failed make[2]: *** [__modpost] Error 1 Makefile:1384: recipe for target 'modules' failed make[1]: *** [modules] Error 2 make[1]: Leaving directory '/usr/src/linux-3.18.22' Makefile:88: recipe for target 'kmod_build' failed make: *** [kmod_build] Error 2 build failed with return value 2 

¿Cómo puedo arreglar esto? He buscado en línea pero no he encontrado mucho sobre eso.

Mi distribución es Debian 8 Jessie, estoy usando sudo dkms autoinstall -k 3.18.22 para comstackr y estoy usando los controlleres oficiales directamente desde el sitio de AMD.

EDITAR: Así que intenté comstackr 4.2.3, que no funcionó como sospechaba, ya que AMD ni siquiera afirma que es compatible con ese núcleo, pero también intenté 3.14.54, que como 3.18.22 es un kernel LTS compatible con los controlleres. 3.14.54 funcionó bien, excepto que es más antiguo que el núcleo con el que Jessie se envía, por lo que es un poco inútil. Supongo que solo es cuestión de 3.18.22 no ser compatible. Es extraño porque se supone que es.