Debian Jessie: ¿Por qué gcc-4.7 está en conflicto con gcc-4.8?

Mi actualización reciente a Jessie eliminó gcc-4.7 de mi sistema e instalé gcc-4.8 en la caja. El problema es que necesito el anterior.

¿Alguien puede explicarme por qué estas dos versiones entran en conflicto en Debian? ¿Hay alguna razón técnica detrás que justifique esto? Mi proyecto requiere un path doloroso para ser comstackble por gcc-4.8 ?

¿Existe una forma segura de instalar gcc-4.7 en paralelo a gcc-4.8 (la compilation no es una opción, tiene que ser un package Debian)?

gcc-4.7 no está incluido en Debian Jessie (ver https://bugs.debian.org/765379 ).

Todavía está en Debian inestable y no entra en conflicto con nada. Como Debian inestable y Debian Jessie son muy similares en este momento (noviembre de 2014), no deberías tener ningún problema.

Ver, por ejemplo, https://wiki.debian.org/AptPreferences o esta respuesta cómo instalar packages de unstable en un sistema de testing .

Intereting Posts