Clon completo del disco encriptado no arrancable en otras computadoras

Hice un clon de disco completo de mi disco S2 encriptado en un disco USB externo con

dd if=/dev/nvme0n1 of=/dev/sdb status=progress 

El disco S2 no se montó durante la clonación, utilicé una distribución en vivo en una memory USB.

Cuando reinicio la computadora arranca desde la unidad USB. Pero cuando conecto la unidad USB a otras computadoras (he intentado con 3) la unidad no es de arranque. Sospecho que el disco S2 se usa de alguna manera durante el process de arranque?

¿Cómo puedo hacer que la unidad USB sea de arranque?

Traté de hacer la primera partición de arranque con parted

 parted set 1 boot on 

pero eso no ayudó. Alos, fdisk quejó de que "GPT PMBR no coincide con el tamaño", pero parece que se solucionó al ejecutar parted .

Hay algunas otras preguntas sobre la clonación de discos en Stack Exchange, pero no parecen tener el problema de que el disco no es de arranque en absoluto.

EDITAR: Ahora he intentado clonar con Clonezilla, pero tengo el mismo problema.

EDIT2: el comentario de @njboot me hace sospechar que este problema está relacionado con el arranque de UEFI.

Hice un poco de progreso en esto, así que aquí hay una respuesta parcial. Utilicé esta respuesta https://askubuntu.com/a/380564/210203 .

En una de las particiones en la unidad externa, copié EFI/debian/grubx64.efi en EFI/BOOT/bootx64.efi . También tuve que activar arranque (híbrido) UEFI en las computadoras donde intenté arrancar desde la copy de security.

Ambas computadoras portátiles ahora arrancan desde el disco de respaldo. Sin embargo, ahorcaron en diferentes lugares en el process de arranque. No sé si los causaron los controlleres que faltan o tal vez get acceso a la partición cifrada.

Puedo intentar más adelante eliminar físicamente el disco que estoy intentando hacer una copy de security y ver si esa computadora arranca desde la copy de security.