Solo se puede inicializar el modo Ad-hoc después de reiniciar iwlwifi mod y network manager

Estoy ejecutando Ubuntu 12.04.4 con la interfaz de networking:

*-network description: Wireless interface product: Centrino Advanced-N 6235 vendor: Intel Corporation physical id: 0 bus info: pci@0000:01:00.0 logical name: wlan0 version: 24 serial: c8:f7:33:8f:d3:9c width: 64 bits clock: 33MHz capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless configuration: broadcast=yes driver=iwlwifi driverversion=3.5.0-48-generic firmware=18.168.6.1 ip=145.94.189.12 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn resources: irq:43 memory:d0400000-d0401fff 

He intentado configurar una networking Ad-hoc en mi computadora portátil desde hace un time. Ya he establecido que funciona casi siempre en casa, pero no en el trabajo (me imagino porque hay más networkinges aquí).

Hoy pensé en replace el controller existente por uno del website del fabricante, aunque parecían ser exactamente iguales. ( iwlwifi-6000g2b-6.ucode , versión 18.168.6.1) Desafortunadamente no hice una copy de security del anterior.

Con el "nuevo" controller de repente pude configurar una networking Ad-hoc nuevamente, usando NetworkManager (0.9.4.0-0ubuntu3):

 * ipv6 ignore * 2.4 GHz (default) * ipv4 manual * WEP 40/128 bit key (Hex or ASCII) * MTU automatic 

o command-line con commands iwconfig (con el apagado de NetworkManager).

 iwconfig wlan0 key 1234567890 iwconfig wlan0 mode ad-hoc iwconfig wlan0 essid MyAdhoc ifconfig wlan0 192.168.1.1 netmask 255.255.255.0 

Pero aquí está el truco, no funciona después de que el NetworkManager establezca otra connection (Infraestructura, WPA2).

Cuando falla al utilizar el NetworkManager, estas líneas aparecen repetidamente en /var/log/kern.log :

 Apr 23 11:01:57 *** kernel: [ 2424.593393] iwlwifi 0000:01:00.0: L1 Enabled; Disabling L0S Apr 23 11:01:57 *** kernel: [ 2424.600237] iwlwifi 0000:01:00.0: Radio type=0x2-0x1-0x0 Apr 23 11:01:57 *** kernel: [ 2424.720967] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready 

y /var/log/syslog donde encuentro el problema con el wpa_supplicant:

 Apr 29 17:13:39 *** wpa_supplicant[8406]: nl80211: Failed to set interface into IBSS mode Apr 29 17:13:39 *** wpa_supplicant[8406]: Association request to the driver failed 

Al intentarlo manualmente, se obtiene (respuesta al iwconfig wlan0 mode ad-hoc ):

 Error for wireless request "Set Mode" (8B06) : SET failed on device wlan0 ; Operation not supported. 

Intenté deshabilitar ipv6 como se sugirió aquí, entre otros, sin get ningún resultado.

Luego intenté editar el file GRUB como se sugiere aquí , lo que significa arrancar con ipv6.disable=1 . Después del reinicio, elimina la tercera línea pero no da como resultado una networking Adhoc.

Si quiero establecer una nueva networking Ad-hoc para restablecer el mod iwlwifi (Y si uso NetworkManager, tengo que ser lo suficientemente rápido para asegurarme de que no se inicie en otra networking primero).

 sudo rmmod iwlwifi sudo modprobe iwlwifi 

¿Alguien tiene una idea de cuál podría ser el problema y cómo resolverlo?