Articles of python

instalar eric5 en CentOS 6.4

Estoy tratando de instalar Eric Python IDE 5 en mi CentOS 6.4. El problema aquí es que incluso he instalado PyQT4 de nuevo diciendo que falta el module. lo que se supone que debo hacer ? aquí está el logging de la terminal [root@localhost eric5-5.3.5]# yum install PyQt4 Loaded plugins: fastestmirror, refresh-packagekit, security Loading mirror […]

¿Cómo puedo cambiar el nombre de los podcasts después de downloadlos con gPodder?

Estoy usando Arch Linux. Para download podcasts, uso gPodder 3. Para escuchar mis podcasts, estoy usando Rockbox en mi iPod Classic. El caso es que los podcasts no se clasifican bien en mi iPod: todo se orderará alfabéticamente. Para superar esto, me gustaría cambiar el nombre del podcast justo después de la descarga a algo […]

¿Cómo verificar el estado del script bash shell mientras se ejecuta desde el script Python?

Tengo un script de Python simple que ejecutará un script de shell usando el module de subprocess en Python. Debajo está mi script de shell de Python que está llamando al script de shell testing.sh y funciona bien. import os import json import subprocess jsonData = '{"pp": [0,3,5,7,9]}' jj = json.loads(jsonData) os.putenv( 'jj3', ' '.join( […]

Retardos de aplicación si se inició desde init.d?

Tengo un progtwig (binary precomstackdo) que, cuando se inicia manualmente en Linux, funciona bien. Tiene una CLI que utilizo para ingresar commands. Este progtwig es un enrutador de software, me puedo conectar a su CLI para ajustar su configuration. Sin embargo, si quiero iniciarlo en el momento del arranque, el progtwig va muy lento, inútilmente. […]

Problemas para instalar lxml con una location de installation personalizada para libxml2 / libxslt

Estoy intentando instalar un module de python llamado lxml en mi count en una supercomputadora que ejecuta RHEL. NO tengo acceso de root o estado de súper usuario. lxml requiere las versiones dev / devel de libxml2 y libxslt , ya que incluyen files de encabezado que lxml necesita comstackr. Pero la supercomputadora tiene las […]

¿Cómo instalar Node.js en CentOS 5.10 con Python 2.4?

Quiero usar Grunt en los sitios web que hemos alojado en nuestro server dedicado WHM. Está ejecutando el estándar CENTOS 5.10 x86_64 con WHM 11.42.1 (compilation 21). Es fundamental que las cosas no se rompan, ya que tenemos más de 20 dominios que ejecutan sitios web en este único server. Traté de build Node.js desde […]

"Make test" falló al comstackr Python

Recopilé Python 3.4.1 en un sistema emulado Debian 7 ARM. make test falló en test_multiprocessing_fork: FAIL: test_semaphore_tracker (test.test_multiprocessing_fork.TestSemaphoreTracker) ———————————————————————- Traceback (most recent call last): File "/root/sources/python3-3.4.1/Lib/test/_test_multiprocessing.py", line 3667, in test_semaphore_tracker _multiprocessing.sem_unlink(name2) AssertionError: OSError not raised Otra testing, test_io, simplemente congela la make test . ¿Cual podría ser el problema? Mi única conjetura es que me […]

Python no puede importar winregistry

secretsdump.py usar secretsdump.py , que se basa en winregistry.py . El error que estoy obteniendo es: Traceback (most recent call last): File "secretsdump.py", line 41, in <module> from impacket import version, smbconnection, winregistry, ntlm ImportError: cannot import name winregistry He usado sys.path para ver de dónde python carga files y copié winregistry.py en algunos de […]

el package checkinstall entra en conflicto con python

Estoy tratando de hacer una actualización de distribución de Debian 6 a 7 y tengo algunos problemas con algunos packages que creé e instalé con checkinstall . Al hacer la actualización, recibo el siguiente post: Preparing to replace python 2.6.6-3+squeeze7 (using …/python_2.7.3-4+deb7u1_all.deb) … Unpacking replacement python … dpkg: error processing /var/cache/apt/archives/python_2.7.3-4+deb7u1_all.deb (–unpack): trying to overwrite […]

¿Cómo usar una biblioteca personalizada para ciertos progtwigs?

Esta es mi situación. Estoy ejecutando Centos 7, tengo la versión estándar de libcurl proporcionada por mi administrador de packages y varios progtwigs que dependen de libcurl. Uno de ellos es pycurl, un enlace de python para libcurl. Creo que carga dinámicamente libcurl cuando se ejecuta Python? Me gustaría que pycurl use una compilation personalizada […]