¿Kate es compatible con HTML5?

Estoy editando un largo documento HTML en Kate, y me encantaría poder "cerrar" las partes en las que no estoy trabajando actualmente. Pero este es un documento nuevo, y el nivel más alto de modularización usa section , no div . Esta es una label HTML, y mi Kate (versión 3.8.4) no lo reconoce. Funciona bien con div y otros elementos más antiguos.

Empecé a search si hay alguna manera de get este apoyo en Kate. Puedo imaginar que mi versión es antigua (es lo que vino con Debian estable), pero no quiero actualizarla a less que la más nueva realmente tenga soporte para HTML5. Extrañamente, no puedo encontrar mucha documentation sobre lo que necesito: ni una list de las "funciones más nuevas" de Kate, ni siquiera la información cuyo número es la versión más reciente.

¿La versión más nueva de Kate tiene soporte HTML5? En caso afirmativo, ¿es aconsejable instalarlo desde la fuente? Después de todo, muchos de mis progtwigs que provienen de los repositorys dependen de Kate, por ejemplo Kile? Y si no tiene soporte HTML5, ¿hay alguna otra forma de getlo, tal vez con algún tipo de complemento?