Imposible instalar packages del repository de raspbian

No puedo instalar ciertos packages en raspbian. Al tratar de instalar los packages ristretto, links2, pqiv, fim, aparece el siguiente error "No se puede detectar el package"

$ sudo apt-get install ristretto Reading package lists... Done Building dependency tree Reading state information... Done E: unable to locate package ristretto $ sudo apt-get install links2 Reading package lists... Done Building dependency tree Reading state information... Done E: unable to locate package links2 $ sudo apt-get install fim Reading package lists... Done Building dependency tree Reading state information... Done E: unable to locate package fim 

Al tratar de instalar FBI, obtengo el siguiente error

enter image description here

Ya probé el command sudo apt-get update.

Han estado atrapados ahora. Estos packages deberían haber estado en el repository raspbian.

¡No se ha podido imaginar qué podría haber pasado para causar este problema!

Gracias @goldilocks, @terdon: Ese parece haber sido el error.

Como sugerí, eché un vistazo a mi raspbian /etc/apt/sources.list y tenía esta línea: deb http://archive.raspberrypi.org/debian/ wheezy main

Lo reemplacé con la línea deb http://mirrordirector.raspbian.org/raspbian/ wheezy main contrib non-free rpi

Ran sudo-apt get update y todos los packages ahora se cargan bien.