Error del linker libxml

Tengo una aplicación que no se enlazará, dando error:

/usr/lib64/libcroco-0.6.so.3: undefined reference to `xmlGetProp@LIBXML2_2.4.30' /usr/lib64/libcroco-0.6.so.3: undefined reference to `xmlFree@LIBXML2_2.4.30' /usr/lib64/libcroco-0.6.so.3: undefined reference to `xmlHasProp@LIBXML2_2.4.30' 

Tengo libxml instalado:

 libxml++.x86_64 2.33.2-1.fc15 @koji-override- 0/$releasever libxml++-devel.x86_64 2.33.2-1.fc15 @fedora libxml2.i686 2.7.8-6.fc15 @fedora libxml2.x86_64 2.7.8-6.fc15 @koji-override-0/$releasever libxml2-devel.x86_64 2.7.8-6.fc15 @fedora libxml2-python.x86_64 2.7.8-6.fc15 @koji-override-0/$releasever 

¿Algunas ideas? ¿Quizás se compiló libcroco con una versión anterior y necesito libxml antiguo instalado?