Dependencias no satisdates al intentar build el browser Chrome en Ubuntu 14.04

Estoy tratando de instalar las dependencies necesarias para build Chromium en Ubuntu 14.04, y estoy frente al siguiente post:

The following packages have unmet dependencies: g++-4.8-multilib : Depends: gcc-4.8-multilib (= 4.8.2-19ubuntu1) but it is not going to be installed Depends: lib32stdc++-4.8-dev (= 4.8.2-19ubuntu1) but it is not going to be installed Depends: libx32stdc++-4.8-dev (= 4.8.2-19ubuntu1) but it is not going to be installed lib32gcc1 : Depends: gcc-4.9-base (= 4.9-20140406-0ubuntu1) but 4.9.1-0ubuntu1 is to be installed libbluetooth-dev : Depends: libbluetooth3 (= 4.101-0ubuntu13) but 4.101-0ubuntu13.1 is to be installed libcairo2-dbg : Depends: libcairo2 (= 1.13.0~20140204-0ubuntu1) but 1.13.0~20140204-0ubuntu1.1 is to be installed libcairo2-dev : Depends: libcairo2 (= 1.13.0~20140204-0ubuntu1) but 1.13.0~20140204-0ubuntu1.1 is to be installed Depends: libcairo-gobject2 (= 1.13.0~20140204-0ubuntu1) but 1.13.0~20140204-0ubuntu1.1 is to be installed Depends: libfontconfig1-dev (>= 2.2.95) but it is not going to be installed libfontconfig1-dbg : Depends: libfontconfig1 (= 2.11.0-0ubuntu4) but 2.11.0-0ubuntu4.1 is to be installed libgbm-dev : Depends: libgbm1 (= 10.1.0-4ubuntu5) libgl1-table-glx:i386 : Depends: libglapi-table:i386 (= 10.1.0-4ubuntu5) Recommends: libgl1-table-dri:i386 (>= 7.2) Conflicts: libgl1 libgl1-table-glx-lts-utopic : Conflicts: libgl1:i386 Conflicts: libgl1-table-glx:i386 libglib2.0-0-dbg : Depends: libglib2.0-0 (= 2.40.0-2) but 2.40.2-0ubuntu1 is to be installed libglib2.0-dev : Depends: libglib2.0-0 (= 2.40.0-2) but 2.40.2-0ubuntu1 is to be installed Depends: libglib2.0-bin (= 2.40.0-2) libgtk2.0-dev : Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed libpango1.0-0-dbg : Depends: libpango-1.0-0 (= 1.36.3-1ubuntu1) but 1.36.3-1ubuntu1.1 is to be installed or libpangocairo-1.0-0 (= 1.36.3-1ubuntu1) but 1.36.3-1ubuntu1.1 is to be installed or libpangoft2-1.0-0 (= 1.36.3-1ubuntu1) but 1.36.3-1ubuntu1.1 is to be installed or libpangoxft-1.0-0 (= 1.36.3-1ubuntu1) but 1.36.3-1ubuntu1.1 is to be installed libpulse-dev : Depends: libpulse0 (= 1:4.0-0ubuntu11) but 1:4.0-0ubuntu11.1 is to be installed Depends: libpulse-mainloop-glib0 (= 1:4.0-0ubuntu11) but 1:4.0-0ubuntu11.1 is to be installed libstdc++6-4.6-dbg : Depends: libgcc1-dbg but it is not going to be installed libudev-dev : Depends: libudev1 (= 204-5ubuntu20) but 204-5ubuntu20.11 is to be installed E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. You will have to install the above packages yourself. 

Dice que tengo que instalar esos packages yo solo, pero ¿cómo hacer esto?

Cuando bash sudo apt-get install <some_package> me dice (ejemplo para gcc-4.8-multilib):

 gcc-4.8-multilib : Depends: lib32gcc-4.8-dev (= 4.8.2-19ubuntu1) but it is not going to be installed Depends: libx32gcc-4.8-dev (= 4.8.2-19ubuntu1) but it is not going to be installed E: Unable to correct problems, you have held broken packages. 

¿Alguien puede ayudarme a resolver la installation de todos estos packages?


ACTUALIZACIÓN 1:

para sudo apt-get install lib32gcc-4.8-dev obtengo:

 lib32gcc-4.8-dev : Depends: lib32gcc1 (>= 1:4.8.2-19ubuntu1) but it is not going to be installed Depends: libx32gcc1 (>= 1:4.8.2-19ubuntu1) but it is not going to be installed Depends: lib32asan0 (>= 4.8.2-19ubuntu1) but it is not going to be installed Depends: libx32asan0 (>= 4.8.2-19ubuntu1) but it is not going to be installed 

y para la apt-cache policy lib32gcc-4.8-dev obtengo:

 lib32gcc-4.8-dev: Installed: (none) Candidate: 4.8.2-19ubuntu1 Version table: 4.8.2-19ubuntu1 0 500 http://ro.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages 

ACTUALIZACIÓN 2:

para sudo apt-get install lib32gcc1 obtengo:

 Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some requinetworking packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: lib32gcc1 : Depends: gcc-4.9-base (= 4.9-20140406-0ubuntu1) but 4.9.1-0ubuntu1 is to be installed E: Unable to correct problems, you have held broken packages. 

y para la apt-cache policy lib32gcc1 obtengo:

  Installed: (none) Candidate: 1:4.9-20140406-0ubuntu1 Version table: 1:4.9-20140406-0ubuntu1 0 500 http://ro.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages 1:4.6.3-1ubuntu5 0 500 mirror://mirrors.ubuntu.com/mirrors.txt/ precise/main amd64 Packages 

Para la apt-cache policy lib32gcc-4.8-dev lib32gcc1 libx32gcc1 lib32asan0 libx32asan0 obtengo:

 lib32gcc-4.8-dev: Installed: (none) Candidate: 4.8.2-19ubuntu1 Version table: 4.8.2-19ubuntu1 0 500 http://ro.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages lib32gcc1: Installed: (none) Candidate: 1:4.9-20140406-0ubuntu1 Version table: 1:4.9-20140406-0ubuntu1 0 500 http://ro.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages 1:4.6.3-1ubuntu5 0 500 mirror://mirrors.ubuntu.com/mirrors.txt/ precise/main amd64 Packages libx32gcc1: Installed: (none) Candidate: 1:4.9-20140406-0ubuntu1 Version table: 1:4.9-20140406-0ubuntu1 0 500 http://ro.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages lib32asan0: Installed: (none) Candidate: 4.8.2-19ubuntu1 Version table: 4.8.2-19ubuntu1 0 500 http://ro.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages libx32asan0: Installed: (none) Candidate: 4.8.2-19ubuntu1 Version table: 4.8.2-19ubuntu1 0 500 http://ro.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages 

ACTUALIZACIÓN 3:

Para la apt-cache policy gcc-4.9-base consigo:

 gcc-4.9-base: Installed: 4.9.1-0ubuntu1 Candidate: 4.9.1-0ubuntu1 Version table: *** 4.9.1-0ubuntu1 0 100 /var/lib/dpkg/status 4.9-20140406-0ubuntu1 0 500 http://ro.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages 

Cuando trato de hacer sudo apt-get purge gcc-4.9-base , sudo apt-get purge gcc-4.9-base :

 Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some requinetworking packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: libgcc1 : Depends: gcc-4.9-base (= 4.9.1-0ubuntu1) but it is not going to be installed libudev1 : Depends: libcgmanager0 but it is not going to be installed Depends: libnih-dbus1 (>= 1.0.0) but it is not going to be installed Depends: libnih1 (>= 1.0.0) but it is not going to be installed libxcb1 : Depends: libxau6 but it is not going to be installed Depends: libxdmcp6 but it is not going to be installed E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. 

abre tu terminal y escribe como

 sudo apt-get autoclean sudo apt-get autoremove sudo apt-get update sudo apt-get dist-upgrade 

sudo apt-get autoclean borra el repository local de los files del package recuperados en /var/cache/apt/archives . La diferencia es que solo elimina los files del package que ya no se pueden download y son en gran medida inútiles.

sudo apt-get autoremove utilizado para eliminar packages que se instalaron automáticamente para satisfacer las dependencies de otros packages y ya no se necesitan.

autoremove y autoremove utilizados para garantizar que no haya packages innecesarios que puedan afectar su sistema.

sudo apt-get update actualiza la list de fonts y vuelve a sincronizar los files de índice del package desde sus fonts.

sudo apt-get dist-upgrade dist-upgrade además de realizar la function de actualización, también maneja inteligentemente las cambiantes dependencies con los packages

Al less algunos de sus packages gcc se instalan manualmente y corresponden a una versión más nueva que las de Ubuntu 14.04. Para instalar g++-multilib y sus dependencies, necesitará degradar esos packages a las versiones en los files.

Comience corriendo

 sudo apt-get install gcc-4.9-base=4.9-20140406-0ubuntu1 

y siga subiendo desde allí … Eso le dará un montón de errores que le indicarán qué otros packages necesita para degradar.

Para degradar los packages, debe ejecutar la apt-cache policy en cada uno para determinar qué versión está en el file (esa es la versión con una URL de trusty ), y agregarla a la línea de sudo apt-get install arriba; para que termines con

 sudo apt-get install gcc-4.9-base=4.9-20140406-0ubuntu1 package1=version1 package2=version2 ... 

Alternativamente, puede simplemente purgar gcc y todos los packages relacionados y volver a instalarlos.

Aparentemente tiene otras bibliotecas con versiones instaladas manualmente, por lo que puede llevar bastante time restaurar su sistema para que coincida con los files.

Mi solución: en el software y la actualización de ubuntu, busque el panel de "actualizaciones", select Actualización de security importante y Actualizaciones recomendadas, luego funciona bien, ¡espero que eso ayude! enter image description here