Actualización de Ubuntu 14.04 a glibc 2.20 o superior

Tengo una aplicación escrita en Go que se cuelga con frecuencia y creo que está relacionada con un problema que se solucionó en glibc 2.20. Mi Ubuntu 14.04.3 LTS tiene glibc 2.19 según ldd --version .

He hecho sudo apt-get update && sudo apt-get dist-upgrade pero ldd --version aún informa 2.19.

El website de glibc tiene la versión 2.20, 2.21 y 2.22.

¿Hay alguna manera de usar apt-get para instalar una de estas versiones más nuevas?

Si apt-get no instala la última versión de glibc es porque los chicos de Canonical todavía lo están probando. Tan pronto como decidan que está listo para su lanzamiento, lo includeán en el repository, por lo que, en lo que respecta a apt-get inquietudes de apt-get , no se puede hacer nada más que esperar.
Puede download, comstackr e instalar glibc usted mismo para tener la última versión, esa es la forma normal de instalar sin un administrador de packages.

Por cierto, podrías search un repository no oficial y agregarlo a tu list de repositorys por casualidad, ya que incluye el último glibc.